Creating Content for
iPod + iTunes

This guide provides information about the file formats you can use when creating
content compatible with iTunes and iPod. This guide also covers using and editing
metadata. To prepare for creating content, you should know a few basics about file
formats and metadata. Knowing about file formats will guide you in choosing the
correct format for your material based on your needs and the content. Knowing
how to use metadata will help you provide your audience with information about
your content. In addition, metadata makes browsing and searching easier. This guide
also includes recommended tools for creating content.

Understanding File Formats

To create and distribute materials for playback on iPod and in iTunes, you need to
get the materials (primarily audio or video) into compatible file formats.
Understanding file formats and how they compare with each other will help you
decide the best way to prepare your materials.

Apple recommends using the following file formats for iPod and iTunes content:
+ AAC (Advanced Audio Coding) for audio content

AAC is a state-of-the-art, open (not proprietary) format. It is the audio format of
choice for Internet, wireless, and digital broadcast arenas. AAC provides audio
encoding that compresses much more efficiently than older formats, yet delivers
quality rivaling that of uncompressed CD audio.

» H.264 for video content

H.264 uses the latest innovations in video compression technology to provide
incredible video quality from the smallest amount of video data. This means you
see crisp, clear video in much smaller files, saving you bandwidth and storage
costs over previous generations of video codecs.

One of the factors to keep in mind when preparing your materials is file size. Using
high-quality compressed formats, such as AAC and H.264, allows files to download
faster and take up less space on your audience’s hard disk.

Note: iPod and iTunes support many other formats, including MP3, MP3 VBR, AIFF,
Apple Lossless, WAV, AA, MPEG-4, and PDF (iTunes only). See the following table for
descriptions and usage.
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This table summarizes the file formats that are available and lists when and why you
might choose one over another.

Audio

File Format

Description

Usage

AAC (Advanced
Audio Coding)

A state-of-the-art, open audio
file format. At any given bit
rate, AAC delivers higher
quality audio than other older
MP3 formats.

AAC provides almost twice
the clarity of MP3 audio at the
same bit rate with equal or
smaller file sizes.

File size: Usually less than 1
MB for each minute of
content

Use when you want CD
quality audio in a highly
compressed file.

AAC is the next generation in
audio formats that offers:

+ Improved compression with
higher quality results and
smaller file sizes

* Increased quality at a wide
range of data rates

+ Support for multichannel
audio, providing up to 48
full frequency channels

+ Higher resolution audio,
yielding sampling rates of
up to 96 kHz

+ Improved decoding
efficiency, requiring less
processing power for
decoding

MP3 A compressed audio format. Offers good quality audio, but
Because it is an older format, compression and quality are
quality is not as high as with not as good as next
newer formats. generation formats.

File size: About 1 MB for each
minute of content

MP3 VBR An enhanced MP3 format that ~ Unless the entire audio

(Variable compresses the audio at composition is complex, MP3

Bit Rate) varying rates based on the VBR provides better overall

content. The compression is
determined moment by
moment; for example, silence
and simple sounds compress
much more than complex
sounds such as reverberation.

sound quality than MP3
without making the file size
too large.
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File Format

Description

Usage

Protected AAC

A file format that is protected
with FairPlay, a DRM (Digital
Rights Management) system
from Apple

Apple uses Protected AAC to
encode copy-protected music
titles purchased from the
iTunes Music Store.

Note: iTunes U does not
place DRM on files or
podcasts you post.

AIFF (Audio
Interchange
File Format)

File format for storing high-
quality digital audio and
musical instrument
information

Uncompressed, CD-quality
audio file format

File size: About 10 MB for each
minute of content

Use for CD-quality audio when
size of file is not an issue.

If you plan to burn high-
quality audio CDs with the
content, you should use the
Apple Lossless or AIFF format
for the best results.

Apple Lossless

CD-quality equal to AIFF

and WAV formats in a smaller
file size. Apple Lossless
compresses CD audio to

50% of its original size. (MP3s
compress to 10% of original.)

File size: 5 MB for each minute
of content

Use for CD-quality audio
when you need a smaller file
size than AIFF or WAV, but not
as compressed as AAC or MP3.

Can be played in iTunes,
applications that support
QuickTime, and iPod models
that come with a Dock
connector.

If you plan to burn high-
quality audio CDs with the
content, you should use the
Apple Lossless or AIFF format
for the best results.

WAV

Native digital audio format in
Windows

Uncompressed, CD-quality
audio file format

File size: About 10 MB for each
minute of content

Use primarily with Windows
computers that are not using
iTunes, or computers that do
not have MP3 software.

Note: iTunes does not write
metadata to WAV files.

AA (formats 2,
3,and 4)

Developed by audible.com for
the spoken word, primarily
audiobooks

Use for spoken word and
audiobooks.




Apple Education
Creating Content for iPod + iTunes

Video
File Format Description Usage
H.264 The next generation video Use when you want very high

compression technology in
the MPEG-4 standard

The result is crisp, clear video
in much smaller files, saving
in bandwidth costs over
previous generations of video
formats. For example, H.264
delivers up to four times the
resolution of MPEG-4 at the
same data rate.

quality across the broadest
range of bandwidths from 3G
mobile devices to iChat AV for
videoconferencing.

Because H.264 is an integral
part of the QuickTime 7
architecture in Mac OS X v10.4
Tiger, QuickTime-based
applications—including iChat
AV, Final Cut Pro, and other
third-party applications—can
take full advantage of this
new video format.

MPEG-4 Video Defined by MPEG (Moving
Picture Experts Group) to
deliver DVD-quality video at
lower data rates and smaller
file sizes than MPEG-2. (MPEG-
2 was defined for DVD video;
MPEG-4 was defined for
Internet delivery of digital
media.)

Based on the QuickTime
architecture

Use to create content in a
simple, cost-effective “author
once, play anywhere” model.
You don't have to manage the
same material in multiple
formats.

Works with a wide variety of
devices, including mobile
phones and digital still
cameras.

PDF booklets PDF stands for Portable
Document Format.
PDF files can be stored and

accessed from within iTunes,
but not on iPod.

Used for text-based books or
articles. PDF extension is
required.

Note: iTunes does not write
metadata to PDF files.

Note: iPod does not support WMA, MPEG Layer 1, or MPEG Layer 2 audio files, or

audible.com format 1.
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Deciding Which Audio Format to Use

The most common Internet audio file formats you might encounter are AAC and
MP3. Although MP3 is widely used, the AAC format offers several advantages,
especially when creating content for delivery:

+ This newer format uses more advanced technology.

« It offers better compression than MP3, which means higher quality results and
smaller file sizes.

+ The format is compatible with iTunes and iPod. (Even listeners who do not have

iPod can still listen through iTunes.)

It supports chapters. (Your listeners can jump to a specific section of your content.)

An enhanced podcast can be divided into chapters, allowing listeners to quickly

navigate to specific parts of the podcast or content. Each chapter can have an

associated piece of artwork.

+ The format provides the ability to incorporate URLs and pictures set to appear at
certain times during playback of audio files. (Images are visible within iTunes and
on iPod with color display. URLS are accessible within iTunes.)

.

Note: You can choose to make your content available in both formats (MP3 and
AAQ), or your listeners can use iTunes to convert AAC files to MP3 files.

What Is Metadata?

Information about information is called metadata. For example, an audio file
contains audio information. The name of the person that created the file, the length
of the file, title of the file, description, and so on, are examples of metadata a file
might contain.

Metadata is useful for several reasons:

+ The iTunes and iPod user interface is built from the metadata. For example,
clicking the Artist category would yield useless results if you didn't enter
information for the artist metadata.

+ It makes browsing and searching much more efficient and helpful to your

audience. Listeners can search by the information in the Artist field, search by your

groupings, or any other category.

It supports and reinforces the content. For example, in an educational context,

metadata meets the needs of different learning styles. There are visual learners

and those who learn better by reading text. A speech of a political leader could
include the text of the speech that listeners can read as they hear the speech, and
it could include a picture of the speaker so listeners can connect emotionally to
the voice.

.

While some metadata may be entered when you publish your files to the server, it is
also important to include some embedded metadata in the file itself. iTunes and
many other applications can display and use this metadata for cataloging as well as
search and retrieval functions. If you add metadata to file formats that support
metadata in iTunes, the metadata stays with the content even if it is moved.



Apple Education
Creating Content for iPod + iTunes

In iTunes, metadata appears when you select a file and choose File > Get Info. There

are five panes: Summary, Info, Options, Lyrics, and Artwork.

Tit i Genre
1:06  William Shakesp... € LiteralSystems.c... & Apple Digit..

Kind:

Size:

Bit Rate:
Sample Rate:
Date Modified:
Play Count:
Last Played:

 Sonnet 40 o
™ Sonnet 55 1:15  William Shakesp.. LiteralSystems.c.. Apple Digit..
- r s
# Sonnet 106 Sonnet 40
# Sonnet 116
Summary | Info Options Lyrics  Artwork ]

{Sonnet 40 (1:06)
William Shakespeare
LiteralSystems.com Audio Books

MPEG audio file Format: MPEG-1, Layer 3
985.7 KB Channels: Mono

96 kbps 1D3 Tag: v2.2

44.100 kHz Encoded with: iTunes v2.0.4
3/5/06 5:44 PM

o

Not available.

The following table includes examples of iTunes metadata categories and some

ideas of how you might use them for nonmusical content.

Metadata Category

Possible Uses

Info pane
Sonnet 40
Summary | Info Options Lyrics  Artwork
LiteralSystems.com Audio Books of
1 of
f:":;p’ré'n]qu'afcamp]s' ] @ [l Part of a compilation
Name Name of the article, lecture, podcast,
episode, and so on
Artist Author, lecturer, or source of the content
Year Year the content was published/created
Album Name of the podcast series, lecture series,
course name, or chapter name/number
Grouping Organize your content by theme (such as

all your lectures on Italian comedic operas
as opposed to the Italian romantic
operas). It might be helpful for your
listeners to sort by grouping.
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Metadata Category

Possible Uses

Comments

Add a brief description of your content,
add a website reference, or your email
address.

Make notes about the content that your
listener might need to know. For example:
“Lecture recorded on April 15, 2006,” or,
“This recording contains lectures 1 and 2.”

Genre

Broad category, for example, by subject
(such as architecture), by publisher, by
organization (such as a university name),
or by type (such as podcast)

Note: Some iTunes users create smart
playlists using the Genre category to
transfer content automatically to iPod.

Lyrics pane

Sonnet 40

Summary Info  Options | Lyrics | Artwork

Xt

Take all my loves, my love, yea, take them all

What hast thou then more than thou hadst before?

Lascivious g shows
Kill me with spites; yet we must not be foes.

For podcasts and other content, you could
include a transcript to support hearing
disabled learners, a summary, a list of
support resources, text for a speech, text
of a poem, or other information.

Note: Lyrics pane is not available for
video.

Artwork pane

Sonnet 40

Summary Info  Options Lyrics | Artwork }

Include an image for the “cover” art for
your content. The image is displayed in
iTunes in the Album art window when the
content is selected. The image is also
shown on an iPod that can display photos
while the audio is being played.
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Preparing Your Files
Preparing your files involves several main steps:

Step 1: Record and edit the audio or video content you want to create for iTunes
and iPod. See “About Creation Tools.”

Step 2: Compress the files for distribution. There are different ways to compress and
decompress audio and video files called codecs. Choose the file format that suits
your needs, balancing audio/video quality with file size. Apple recommends using
AAC for audio and H.264 for video. Some applications will compress the file if you
export it for iPod. Others, you can compress using iTunes.

Step 3: Once the file is compressed, add embedded metadata. iTunes itself can be
used to add metadata to files that accept metadata. Metadata is descriptive
information about the content (sometimes referred to as a tag). This might include
an image, detailed descriptions, author, and copyright information. For more
information, see “What Is Metadata?” earlier in this document.

Step 4: Distribute the content through iTunes U or by other means.

Step 5: Your audience can access the content through the Internet and download it
to iTunes where they can sync the content to iPod or listen to it on their computers
using iTunes.

About Creation Tools

You can choose from several different tools to create your audio and video content.
This section briefly describes some of the applications you might use. For in-depth
instructions, see the manual that comes with the application.

QuickTime Pro

While QuickTime is installed on every Macintosh, you must purchase a registration
code to gain access to its authoring features. With the full-featured version, called
QuickTime Pro, you can create and edit video and audio content. After creating your
content, you can export your QuickTime movie and choose the export format,
including Export to iPod, in addition to a number of different file formats, such as
MPEG-4. When you export to iPod or to MPEG-4, your content is automatically
compressed.

iMovie HD

You can use video from a variety of sources and devices to create a movie in
iMovie HD. If you have some digital video in your camcorder or digital video
footage on your computer, you can follow the steps in the iMovie HD Getting
Started manual (available from the Help menu in iMovie HD) to automatically
transfer it to iMovie HD, edit the clips, add transitions and a title, and lay down a
soundtrack. After creating your movie, you can export it for use on the Internet or
for an iPod. It is as easy as choosing iPod from the Share menu.
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Soundtrack Pro

Soundtrack Pro is a professional multitrack sound recording and editing application
with built-in effects and filters, such as audio cross dissolve, normalization of audio
level, and equalization. After recording the audio, export to AIFF. You can then bring
it into iTunes to compress it.

GarageBand

GarageBand is a multitrack capture tool and editor for both audio and MIDI sound.
With GarageBand, you can capture audio from input sources and use effects and
filters to enhance the audio’s quality. GarageBand 3 is a component of the iLife ‘06
application suite from Apple and may already be installed on your computer.
GarageBand can add certain metadata fields to the file and encode it as AAC for
playback on iPod and in iTunes.

Compressing Your File

Once you have created your content, you can compress it in the following ways:

+ In some applications (such as QuickTime Pro and iMovie HD), you can compress
the file when you export it.

* You can import an uncompressed file into iTunes and then compress it.

+ You can compress several files at once using a range of tools that do batch
processing, such as Compressor 2, included with Final Cut Studio.

To compress a file using iTunes, make sure the file you want to compress is in the
iTunes Library. To import the file into the iTunes Library, choose File > Import. Find
and select the audio or video file to compress in the iTunes Library. To compress an
audio file, choose Advanced > Convert Selection to AAC (requires iTunes importing
preferences to be set to AAC). To compress a video, select the file within your iTunes
library and choose Advanced > Convert Selection for iPod.

Note: If the file is already compressed, you should not recompress it—that will
lower the quality. You can tell if a file is already compressed by selecting the file in
the iTunes Library, then choosing File > Get Info. In the Get Info Summary pane,
compressed files will display the Kind as AAC or MP3 audio for audio files and
MPEG-4 for video files.

Adding Metadata to Your File

You can use iTunes to add metadata about your content. iTunes and many other
applications can display and use this metadata for cataloging as well as search and
retrieval functions. To add metadata, select the file in the iTunes Library and choose
File > Get Info.

Some applications, such as GarageBand, can add metadata prior to exporting.
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